PAT1076.Forwards on Weibo

题目

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

1
M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

1
2
3
4
5
6
7
8
9
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

1
2
4
5

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
#include <iostream>
#include <cstdio>
#include <vector>
#include <set>
#include <queue>
using namespace std;
vector<int> adj[1005];
struct node {
    int id;
    int layer;
    node(int _id,int _layer): id(_id),layer(_layer){}
};
int n,level;

int bfs(int u)
{
    bool vis[1005]={false};
    set<int> res;
    queue<node> Q;
    node root =node(u,0);
    vis[root.id]=true;
    Q.push(root);

    while(!Q.empty())
    {
        node next=Q.front();
        Q.pop();
        for(int i=0;i<adj[next.id].size();i++)
        {
            node tmp=node(adj[next.id][i],next.layer+1);
            if(vis[tmp.id]==false&&tmp.layer<=level)
            {
                vis[tmp.id]=true;
                res.insert(tmp.id);
                Q.push(tmp);
            }
        }
    }

    return res.size();
}

int main()
{
    int m,t;
    scanf("%d%d",&n,&level);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&m);
        for(int p=0;p<m;p++)
        {
            scanf("%d",&t);
            adj[t].push_back(i);
        }
    }

    scanf("%d",&m);
    for(int p=0;p<m;p++)
    {
        scanf("%d",&t);
        printf("%d\n",bfs(t));
    }

    return 0;
}

分析

思路是层序遍历,层序遍历在BFS的基础上使用结构体对节点的层序进行记录并以此为依据进行下一层遍历。注意

  1. bfs中的vis用来记录节点是否已经入过队,要在入队的时候对vis进行修改,原先我把vis放在Q.pop()的位置,会造成一个节点重复入队(当前队列中AB两个节点都能到达C,会把C入队两次),最后一个测试样例会因此超时。
Licensed under CC BY-NC-SA 4.0
Built with Hugo
主题 StackJimmy 设计