PAT1003.Emergency

题目

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then Mlines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

1
2
3
4
5
6
7
8
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

1
2 4

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
#include <iostream>
#include <cstdio>

using namespace std;
const int maxv=505;
const int INF=1000000000;
int paths[maxv]={0};//路径数量
int w[maxv];//点权
int res[maxv]={0};//路径上的点权和
int G[maxv][maxv];
int dis[maxv];
bool vis[maxv]={false};
int m,n,p,q;


void dijkstra()
{
    fill(dis,dis+maxv,INF);
    dis[p]=0;
    res[p]=w[p];
    paths[p]=1;

    for(int i=0;i<n;i++)
    {
        int u=-1,MIN=INF;
        for(int j=0;j<n;j++)
        {
            if(vis[j]==false&&dis[j]<MIN)
            {
                u=j;
                MIN=dis[j];
            }
        }
        if(u==-1) return;
        vis[u]=true;

        for(int v=0;v<n;v++)
        {
            if(vis[v]==false&&dis[u]+G[u][v]<=dis[v])
            {
                if(dis[u]+G[u][v]==dis[v])
                {
                    if(res[u]+w[v]>res[v])
                        res[v]=res[u]+w[v];
                    paths[v]+=paths[u];
                }
                else // <
                {
                    dis[v]=dis[u]+G[u][v];
                    res[v]=res[u]+w[v];
                    paths[v]=paths[u];
                }
            }
        }


    }

}



int main()
{
    fill(G[0],G[0]+maxv*maxv,INF);
    scanf("%d%d%d%d",&n,&m,&p,&q);
    for(int i=0;i<n;i++)
        scanf("%d",&w[i]);

    for(int i=0;i<m;i++)
    {
        int r,s,t;
        scanf("%d%d%d",&r,&s,&t);
        if(t<G[s][r])
            G[s][r]=G[r][s]=t;
    }

    dijkstra();
    printf("%d %d\n",paths[q],res[q]);




    return 0;
}

思路

dijkstra最短路径

Licensed under CC BY-NC-SA 4.0
Built with Hugo
主题 StackJimmy 设计