PAT1069. The Black Hole of Numbers

题目

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089\ 9810 - 0189 = 9621\ 9621 - 1269 = 8352\ 8532 - 2358 = 6174\ 7641 - 1467 = 6174\ … …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation “N

  • N = 0000”. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

1
6767

Sample Output 1:

1
2
3
4
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

1
2222

Sample Output 2:

1
2222 - 2222 = 0000

分析

跟着题意做没有障碍。

遇到一个坑:

printf("%04d - %04d = %04d\n",a,b,a=a-b);

本意是想先输出a,b,a-b。再把a-b赋值给a。结果先执行了a=a-b,这样第一个输出的数字就是a-b了。

温习一下printf的用法

  • %md 对不足m位的整数以m位进行右对齐输出,即前面补空格
  • %0md 不足m位的时候前面补0
  • %.mf 以精确到小数点后m位输出,四舍六入五成双的规则,若要四舍五入要用round。

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

void itoArray(int n,int (&C)[4])
{
    for(int i=3;i>=0;i--)
    {
        C[i] = n%10;
        n /= 10;
    }
}
void reverseArray(int *A,int (&B)[4])
{
    for(int i=0;i<4;i++)
        B[i]=A[3-i];
}
void arraytoInt(int *C,int &n)
{
    n = 0;
    for(int i=0;i<4;i++)
    {
        n *= 10;
        n +=C[i];
    }
}
bool cmp(int a,int b)
{
    //使sort函数从大到小排序
    return a>b;
}
int main()
{
    int A[4];
    int B[4];
    int a,b;
    scanf("%d",&a);
    itoArray(a,A);
    sort(A,A+4,cmp);
    arraytoInt(A,a);
    reverseArray(A,B);
    arraytoInt(B,b);

    while(true)
    {
        printf("%.4d - %.4d = %.4d\n",a,b,a-b);
        if((a=a-b)==0||a==6174) break;
        itoArray(a,A);
        sort(A,A+4,cmp);
        arraytoInt(A,a);
        reverseArray(A,B);
        arraytoInt(B,b);
    }
    return 0;
}
Licensed under CC BY-NC-SA 4.0
Built with Hugo
主题 StackJimmy 设计