PAT1025. PAT Ranking

题目

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct student{
    char id[14];
    int score;
    int location;
    int lock_rank;
}stu[30001];

bool cmp1(student a,student b)
{
    if(a.score == b.score)
        return strcmp(a.id,b.id)<0;
    return a.score>b.score;
}

int main()
{
    int n,k,p=0;
    scanf("%d",&n);
    for(int t=1;t<=n;t++)
    {
        scanf("%d",&k);
        for(int i=0;i<k;i++)
        {
            scanf("%s %d",stu[p+i].id,&stu[p+i].score);
            stu[p+i].location = t;
        }

        sort(stu+p,stu+p+k,cmp1);
        int q=1;
        stu[p].lock_rank=1;
        int same=1;
        for(int i=1;i<k;i++)
        {
            if(stu[p+i-1].score > stu[p+i].score)
            {
                q = q+same;
                stu[p+i].lock_rank = q;
                same = 1;
            }
            else
            {
                stu[p+i].lock_rank = q;
                same ++;
            }
        }
        p += k;
    }
        sort(stu,stu+p,cmp1);
        int r=1;
        int same=1;
        printf("%d\n",p);
        printf("%s 1 %d %d\n",stu[0].id,stu[0].location,stu[0].lock_rank);
        for(int i=1;i<p;i++)
        {
            if(stu[i-1].score > stu[i].score)
            {
                r += same;
                same=1;
                printf("%s %d %d %d\n",stu[i].id,r,stu[i].location,stu[i].lock_rank);
            }
            else
            {
                same ++;
                printf("%s %d %d %d\n",stu[i].id,r,stu[i].location,stu[i].lock_rank);
            }
        }


    return 0;
}

分析

题目不难,主要是太久没练手了,磕磕碰碰。

以及,上一篇写的vscode环境实际用起来体验糟糕,最后还是上了codeblocks,╮( ̄▽ ̄")╭。

Licensed under CC BY-NC-SA 4.0
Built with Hugo
主题 StackJimmy 设计