PAT1101.Quick Sort

题目

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

1
2
5
1 3 2 4 5

Sample Output:

1
2
3
1 4 5

分析

一个元素为枢纽必须比左边所有元素大,且比右边所有元素小。利用两个数组leftBig和rightSmall分别记录坐标最大元素和右边最小元素。则判断条件为input[i]<rightSmall[i]&&input[i]>leftBig[i]。

然后边界要的元素要注意一下。

一个无聊的坑是如果count==0,最后要多加一个空行不然格式错误。

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include<cstdio>

#define MAX 1e9+10
int input[100001];
int leftBig[100001];
int rightSmall[100001];
int output[100001];
int main()
{
    int n;
    int count=0;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",&input[i]);

    rightSmall[n-1] = MAX;

    leftBig[0] = 0;

    for(int i=n-2;i>=0;i--)
        if(input[i+1]<=rightSmall[i+1])
            rightSmall[i]=input[i+1];
        else
            rightSmall[i]=rightSmall[i+1];

    if(input[0]<rightSmall[0])
        output[count++]=input[0];


    for(int i=1;i<n;i++)
    {
        if(input[i-1]>=leftBig[i-1])
            leftBig[i]=input[i-1];
        else
            leftBig[i]=leftBig[i-1];

        if(input[i]<rightSmall[i]&&input[i]>leftBig[i])
            output[count++]=input[i];
    }

    printf("%d\n",count);
    for(int i=0;i<count;i++)
    {
        if(i!=0)printf(" ");
        printf("%d",output[i]);
    }
    printf("\n");
    return 0;
}
Licensed under CC BY-NC-SA 4.0
Built with Hugo
主题 StackJimmy 设计